安装 gcc-c++ 时报错和原有 gcc 版本冲突

6.7 安装 gcc-c++时报下面的错误:

Resolving Dependencies
–> Running transaction check
—> Package gcc-c++.i686 0:4.4.7-11.el6 will be installed
–> Processing Dependency: libstdc++-devel = 4.4.7-11.el6 for package: gcc-c++-4.4.7-11.el6.i686
–> Processing Dependency: gcc = 4.4.7-11.el6 for package: gcc-c++-4.4.7-11.el6.i686
–> Running transaction check
—> Package gcc-c++.i686 0:4.4.7-11.el6 will be installed
–> Processing Dependency: gcc = 4.4.7-11.el6 for package: gcc-c++-4.4.7-11.el6.i686
—> Package libstdc++-devel.i686 0:4.4.7-11.el6 will be installed
–> Finished Dependency Resolution
Error: Package: gcc-c++-4.4.7-11.el6.i686 (c6-media)
          Requires: gcc = 4.4.7-11.el6
          Installed: gcc-4.4.7-16.el6.i686 (@base)
              gcc = 4.4.4-15.el6
              gcc = 4.4.7-16.el6
          Available: gcc-4.4.7-11.el6.i686 (c6-media)
              gcc = 4.4.7-11.el6
              gcc = 4.4.4-15.el6
 You could try using –skip-broken to work around the problem
 You could try running: rpm -Va –nofiles –nodigest

解决办法:将 gcc,cpp, libgomp 等等依赖先删除掉,然后重新直接安装 gcc-c++,让其自动安装它的正确版本的依赖的 gcc, cpp, libgomp:

[root@localhost ~]# yum install gcc-c++
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * c6-media:
Resolving Dependencies
–> Running transaction check
—> Package gcc-c++.i686 0:4.4.7-11.el6 will be installed
–> Processing Dependency: libstdc++-devel = 4.4.7-11.el6 for package: gcc-c++-4.4.7-11.el6.i686
–> Processing Dependency: gcc = 4.4.7-11.el6 for package: gcc-c++-4.4.7-11.el6.i686
–> Running transaction check
—> Package gcc.i686 0:4.4.7-11.el6 will be installed
–> Processing Dependency: libgomp = 4.4.7-11.el6 for package: gcc-4.4.7-11.el6.i686
–> Processing Dependency: cpp = 4.4.7-11.el6 for package: gcc-4.4.7-11.el6.i686
–> Processing Dependency: libgomp.so.1 for package: gcc-4.4.7-11.el6.i686
—> Package libstdc++-devel.i686 0:4.4.7-11.el6 will be installed
–> Running transaction check
—> Package cpp.i686 0:4.4.7-11.el6 will be installed
—> Package libgomp.i686 0:4.4.7-11.el6 will be installed
–> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================================================================
 Package                              Arch                      Version                            Repository                      Size
==========================================================================================================================================
Installing:
 gcc-c++                              i686                      4.4.7-11.el6                      c6-media                      4.3 M
Installing for dependencies:
 cpp                                  i686                      4.4.7-11.el6                      c6-media                      3.4 M
 gcc                                  i686                      4.4.7-11.el6                      c6-media                      8.2 M
 libgomp                              i686                      4.4.7-11.el6                      c6-media                      135 k
 libstdc++-devel                      i686                      4.4.7-11.el6                      c6-media                      1.6 M

Transaction Summary
==========================================================================================================================================
Install      5 Package(s)

Total download size: 18 M
Installed size: 43 M
Is this ok [y/N]: y
Downloading Packages:
——————————————————————————————————————————————
Total                                                                                                      21 MB/s |  18 MB    00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : libstdc++-devel-4.4.7-11.el6.i686                                                                                      1/5
  Installing : cpp-4.4.7-11.el6.i686                                                                                                  2/5
  Installing : libgomp-4.4.7-11.el6.i686                                                                                              3/5
  Installing : gcc-4.4.7-11.el6.i686                                                                                                  4/5
  Installing : gcc-c++-4.4.7-11.el6.i686                                                                                              5/5
Unable to connect to dbus
  Verifying  : gcc-c++-4.4.7-11.el6.i686                                                                                              1/5
  Verifying  : libgomp-4.4.7-11.el6.i686                                                                                              2/5
  Verifying  : gcc-4.4.7-11.el6.i686                                                                                                  3/5
  Verifying  : libstdc++-devel-4.4.7-11.el6.i686                                                                                      4/5
  Verifying  : cpp-4.4.7-11.el6.i686                                                                                                  5/5

Installed:
  gcc-c++.i686 0:4.4.7-11.el6

Dependency Installed:
  cpp.i686 0:4.4.7-11.el6      gcc.i686 0:4.4.7-11.el6      libgomp.i686 0:4.4.7-11.el6      libstdc++-devel.i686 0:4.4.7-11.el6

Complete!
[root@localhost ~]#

可以看到安装 gcc-c++ 成功了。

升级GCC 4.8.1清晰简明教程(

6.4中安装GCC 4.8.1 + GDB 7.6.1 + Eclipse 在 6.4中安装GCC 4.8.1 + GDB 7.6.1 + Eclipse

Ubuntu下Vim+GCC+GDB安装及使用 

Ubuntu下两个GCC版本切换 

CentOS6.5升级手动安装GCC4.8.2 

GCC 的详细介绍

转载自:https://www.linuxidc.com/Linux/2015-11/124943.htm

声明: 除非转自他站(如有侵权,请联系处理)外,本文采用 BY-NC-SA 协议进行授权 | 智乐兔
转载请注明:转自《安装 gcc-c++ 时报错和原有 gcc 版本冲突
本文地址:https://www.zhiletu.com/archives-5225.html
关注公众号:智乐兔

赞赏

wechat pay微信赞赏alipay pay支付宝赞赏

上一篇
下一篇

相关文章

在线留言

你必须 登录后 才能留言!